You need mysql_config, so on debian that means installing libmysqlclient-dev.

apt-get install libmysqlclient-dev
cpanm -l /opt/perl DBD::mysql

Similarly, for DBD::Oracle you need an oracle client, but that’s no surprise since you would need one for connecting anyway.

Advertisements